Unanswered question

Search / Flag requests not working for Variable modifier

When we want to identify the variables used in the script using flag request or find using "search and replace" option, the variables inside the "variable modifier" step is not flagged or found during the search. Any idea why?

Rajagopal B.
Rajagopal B.

Rajagopal B.

Level
1
346 / 750
points

Answers

Christophe M.
Christophe M.

Christophe M.

Level
3
2727 / 5000
points
Team

If you want to flag Variable Modifiers based on 'MyVar' predefined variable name, then enter 'MyVar' for the choice 'whose definition contains' of the Flagger.

Rajagopal B.
Rajagopal B.

Rajagopal B.

Level
1
346 / 750
points

Hi Christophe,

Tried the same. See screenshot.

Christophe M.
Christophe M.

Christophe M.

Level
3
2727 / 5000
points
Team

You should search for 'SQ1' not '${SQ1}' .

Rajagopal B.
Rajagopal B.

Rajagopal B.

Level
1
346 / 750
points

Not working with only SQ1

Christophe M.
Christophe M.

Christophe M.

Level
3
2727 / 5000
points
Team

I confirm there's a problem, the Flagger only looks into 'Predefined variable / name' not in 'Shared Queue / name'.

The bug has been reported with id #8959

Rajagopal B.
Rajagopal B.

Rajagopal B.

Level
1
346 / 750
points

I think flagging is not working on "variable modifier" step where Shared Queue section is selected. I tried with the variable inside the "add the value" and it doesn't work.

Christophe M.
Christophe M.

Christophe M.

Level
3
2727 / 5000
points
Team

This bug has been fixed and will be available in next bug fix release (5.1.4).