Unanswered question

Unable to record application

I am unable to record any application through neoload,found below error in Neoload Log files

ERROR - neoload.Proxy.ScreenshotHandler: Failed to init screenshot component. java.lang.IllegalArgumentException: No window found matching the title.
at com.neotys.nl.gui.b.eb.<init>(eb.java:80)
at com.neotys.nl.controller.k.qb.run(qb.java:87)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)

Answers

Nouredine A.
Nouredine A.

Nouredine A.

Level
4
5000 / 5000
points
Team

That error should not prevent you to record any applications. It's just the screen shot feature that is not enable to capture the windows.

Could you describe your setup when you access your application without NeoLoad. Do you need a proxy? Do you have issues with HTTP and/or HTTPS applications?

You said that you are unable to record, does it mean that you can reach your application but nothing is recorded or you can't even reach your application when recording with NeoLoad?

We have deployed a sample dot.net application on our local machine , i am able to access this without proxy through browser, i am able to reach the application through neoload.

Nouredine A.
Nouredine A.

Nouredine A.

Level
4
5000 / 5000
points
Team

Ok so if it's a local application, make sure to use the IP address in the URL otherwise it won't be recorded since your browser is configured to bypass any proxy for local URL.

Let me know if works better with the IP.

Nouredine A.
Nouredine A.

Nouredine A.

Level
4
5000 / 5000
points
Team

You're right i missed that point. In that case please follow the procedure below:

  1. Start your browser
  2. Change the proxy settings to "localhost:8090"
  3. Start a NeoLoad recording without starting the browser. Just uncheck the option
  4. Enter your URL in the browser windows started in point 1

 

I assume that you did not change the NeoLoad proxy port which is 8090 by default. You can see it in the NeoLoad preferences.

Plus i also assume that you do not have any other applications using that port. But since you have a local web server running, make sure that there's no port conflict otherwise change 8090 by another unused port.