Answered question

Orders not getting created when load test runs

I have recorded order creation through neoload and now running load test with 10 virtual users. The load test successfully executes without errors but when I check the application the orders have not been created. I was expecting at least 10 orders in the application created by load test.
Could you please help

Nitin N.
Nitin N.

Nitin N.

Level
0
14 / 100
points
christophe M.
christophe M.

christophe M.

Level
3
3985 / 5000
points
Team

Beware, NeoLoad does not detect all errors automatically. Even if HTTP error codes are detected by NeoLoad as a cause of a failed validation, functional errors (such as the incorrect playback of a business transaction) can escape detection. This is because applications often return pages in error that contain valid HTTP codes. Therefore, it is important to make sure that the content or HTML rendering does in fact correspond to the expected result. For example, an incorrectly played-back login often produces an HTML page stating that "the login or password is incorrect".

Validate first your Virtual User with the Check VU dialog (see Checking a Virtual User)

Learn more about the whole design process in the documentation.

Did you find this useful ?

No (0)

Yes (1)

100%

100% of users found this answer useful

Other answers

Nitin N.
Nitin N.

Nitin N.

Level
0
14 / 100
points

Thanks Chrisopher. yes I tried a simple scenario and it has created order for me now. thanks. Must be some error