Answered question

I installed NLS on Linux but when I run the Administration console, i get an error of missing library

My Linux machine is a Red Hat 64 bits version. I was able to install the NLS using the archive file but it seems that the Administration console is not finding that library“” and I checked and it is actually installed.

The Neotys License Server  (NLS) can be installed using the archive (tar.gz) or the installer (.sh) files.

NLS uses a 32 bits JRE but it can be used on 64 bits machines. On those machines, since NLS is a 32 bits application, you have to install some 32 bits compatibility libraries.

The way to install them depends on your Linux flavor but for Red Hat/CentOs, you can install them like this:


yum install libXt.{i686,x86_64} <--- Choose either i686 or x86_64


yum install libXtst.i686


Under Ubuntu/Debian, you can install that package to get the 32 bits compatibility libraries:


apt-get install ia32-libs


For more information, see “Installation” section in Neotys License Server  documentation.

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful