Unanswered question

ERROR: node is running secure mode, SSL connection required when trying to connect cockroachdb?

I am trying to connect cockroachdb via Neoload and mentioned all the required parameter in the connection settings. It's still asking SSL connection is required.

Please suggest how to configure SSL parameter in the connection settings? I have attached the screenshot for reference.

Jabastin P.
Jabastin P.

Jabastin P.

Level
0
52 / 100
points

Answers

Have you tried to add such parameters: sslmode=verify-ca, sslfactory=org.postgresql.ssl.DefaultJavaSSLFactory using the parameters connection.property for example like this: connection.sslfactory and connection.sslmode?

 

Jabastin P.
Jabastin P.

Jabastin P.

Level
0
52 / 100
points

Yes, I tried all the best possible settings already. I exposed the connection to my localhost with port 8080 and tried to connect the db with settings mentioned above.

I have a certificate files to connect to the postgreSQL (cockroachdb).
1) server.pk8 – private key
2) server.crt – server certificate
3) root.crt – trusted root certificate

Would like to know how to configure those cert files as a parameters (syntax) in neoload?