Unanswered question

Check a User Path taking more time to validate

I have around 12 user path (each user path will have at least 2-3 web service calls).

When I am trying to check user path, it is taking longer time. Typically it is taking around 1 min 30 seconds every time.

Though I have more than 10 User Paths, I am trying to validate only one at a time.

Also I do not have any think time or pacing and disabled time taking settings in the Advanced (User Path).

I have increased the memory usage of my localhost LG. But still the time is taking longer than usual.

This issue I never faced and no changes has been done.Only change I had done is: added Dynatrace User path to my project.

Version : 7.2.1
Project settings: XML

Please share your insights.

Naveenkumar N.
Naveenkumar N.

Naveenkumar N.

Level
0
56 / 100
points

Answers

Could you describe a bit that behavior? Is it the starting of the LG that is taking time or the execution of your web service calls?

If the latter do you get high response time for those requests or is it taking time between the execution of the requests?

Could you provide a screen shot so we can understand better?

Thanks

Naveenkumar N.
Naveenkumar N.

Naveenkumar N.

Level
0
56 / 100
points

Attached is the timestamps. It is taking 1 min to complete.

Naveenkumar N.
Naveenkumar N.

Naveenkumar N.

Level
0
56 / 100
points

yes, but after clicking on "Start Checking" cursor is spinning for a minute and then it is executing.

Naveenkumar N.
Naveenkumar N.

Naveenkumar N.

Level
0
56 / 100
points

Please check the attachments.

Ok thanks. So it's the time to the LG to start. When you hit the "Start Checking" button a new java.exe process is spawned. This is the LG process. If it takes time that means that either your machine is too slow or an anti-virus is slowing down the LG process. Also during that starting process the project is sent locally to the LG. So again a lack of ressources might lead to such issue.

You can check the task manager while the LG is starting and look after that java.exe process. Check if any CPU used by other processes.

You can try from another machine to see if you have the same issue as well.

Naveenkumar N.
Naveenkumar N.

Naveenkumar N.

Level
0
56 / 100
points

I just tried in another machine where I am able to execute within 5 seconds. Also, I checked with my colleagues system, no issues. Not sure why I am facing this issue suddenly. I am not seeing java.exe process when LG is starting. Am I missing something here?

Can you see that java.exe process in the other machines? In your case it may take time to start but it should be there. Make sure to display all the processes. Also sort by CPU usage to see it as it should be the process that is going to take CPU/Memory.

Naveenkumar N.
Naveenkumar N.

Naveenkumar N.

Level
0
56 / 100
points

I got the issue :) Actually my admin rights has been expired last week. Just got the admin rights and launched NeoLoad as an administrator. It is executing with in 8 seconds. I did catch java process which took ~20% of CPU.