Unanswered question

Does Neoload still have the problem of handling the Gzip, Deflate Encoding ?

I work with Neoload 6.10.0 version and i'm trying to send a web service request using GET Method;
I tested the same request with Postman and it works well, i get 200 on my reponse, but when i try it on neoload it gives me this answer :
Accept-Encoding must contain gzip, deflate (with 406 on the Response Code).
do you think that is normal ?

Rachid K.
Rachid K.

Rachid K.

4 / 100


In the request that you have created in NeoLoad did you add an HTTP header "Accept-Encoding" in your request?

NeoLoad is configured to use br,deflate,gzip but it can be customized in the Advanced settings of the checkvu panel.

But the best to avoid any mistake since you already have your request in Postman is to execute it from there and record it in NeoLoad.

To do so you just need to set as proxy in Postman "localhost:8090" if NeoLoad is running on the same machine or with "IP:8090" where IP is your NeoLoad machine.

If your WebService is HTTPS make sure in Postman to configure it so the validity of the certificate is not checked otherwise the recording won't work.