Unanswered question

NL-RECORDING-NOT-LICENSED error while trying to convert SAP GUI script from Tosca 12.2

Hi Team, we are working on converting Tosca SAP GUI script to Neoload. when I click on Transfer to Neoload I see below error in the Neoload add-on error.txt. please let me know what is required?
Neotys.CommonAPI.Error.NeotysAPIException
Message : NL-RECORDING-NOT-LICENSED
StackTrace : at Neotys.CommonAPI.Client.NeotysAPIClientOlingo.WriteEntity(IEdmModel edm, String url, String entitySetName, IDictionary`2 data)
at Neotys.DesignAPI.Client.DesignAPIClientOlingo.ContainsUserPath(ContainsUserPathParams containsUserPathParams)
at NeoLoad.Client.NeoLoadDesignApiInstance.StartSapRecording() in C:\Neotys\NL\TRK\W\Tricentis-Tosca\client\NeoLoadDesignApiInstance.cs:line 57

Narendar Reddy C.
Narendar Reddy C.

Narendar Reddy C.

Level
0
42 / 100
points

Answers

Narendar Reddy C.
Narendar Reddy C.

Narendar Reddy C.

Level
0
42 / 100
points

When I tried to convert Tosca script including Launch SAP GUI and authentication steps this error is coming up. If I convert other than login this error is not coming up. Neotys has to confirm this.

Alexis N.
Alexis N.

Alexis N.

Level
2
1170 / 2000
points
Team

A NeoLoad license with the Integration & Advanced Usage module is needed on the NeoLoad Controller.

Narendar Reddy C.
Narendar Reddy C.

Narendar Reddy C.

Level
0
42 / 100
points

Hi Alexis, I could see on github page that it works with free version as well. This is no longer an issue if I skip Launch and Login part.

Alexis N.
Alexis N.

Alexis N.

Level
2
1170 / 2000
points
Team

You should not skip Launch and Login part. You have this error because you don't have a NeoLoad License. You can request and install a free license of NeoLoad: https://www.neotys.com/download