Answered question

How to specify a proxy for a project launched by a Windows Jenkins slave ?

Hi,
I tried to run a Neoload project on a Jenkins slave (Windows). This project needs an application proxy.
The Jenkins slave runs as a Windows Service with a local system account, so the Neoload Injector doesn't have access to a controller_user.properties (specificly the [proxy] section) when it's launched by Jenkins.
Naturally, the test failed (I see in the result / Execution Context that Application Proxy = 'none' while I specified an application proxy in the project).
I tried to manually copy the [proxy] section form a controller_user.properties to the Neoload\conf\controller.properties of the Jenkins slave, but it does not work either.
So I tried to start the Jenkins slave service with a user account (that has an AppData\Roaming\Neotys\controller_user.properties file), and the project finally works.

Is this the only way to proceed? Or can I have a controller_user.properties associated with a local system account ?
thank you.

Jean-Baptiste B.
Jean-Baptiste B.

Jean-Baptiste B.

Level
0
3 / 100
points

if you are running Neoload as a system account (service), the neoload settings are in C:\Windows\System32\config\systemprofile\AppData\Roaming\Neotys\NeoLoad\v6.x\conf\

Did you find this useful ?

No (0)

Yes (1)

100%

100% of users found this answer useful