Unanswered question

"If-None-Match" header field is automatically being inserted in request header

If-None-Match header with "e-tag value" field is automatically being inserted into AWS CompleteMultipartUpload request headers by NeoLoad. How do I stop NeoLoad from automatically inserting this field into my request headers?

We tried Population settings, the 'Handle cache' setting : New user
But no luck.

Thanks in advance,
Chinnikrishna.

CHINNIKRISHNA REDDY B.
CHINNIKRISHNA REDDY B.

CHINNIKRISHNA REDDY B.

Level
0
60 / 100
points

Answers

Nouredine A.
Nouredine A.

Nouredine A.

Level
4
5000 / 5000
points
Team

If NeoLoad added that If-None-Match header that means that it's probably the second time that this request is executed within your script. Could you check if it's the case?

If yes then it sounds to me that it's the correct behavior whatever the handle cache settings.

There's a way to not add this header would be to empty the cache using this Javascript method: context.currentVU.clearCache();

But it will clear the cache globally until it is full again.

Another way could be to disable cache at all for specific HTTP methods like POST, GET, PUT etc....

  1. Stop NeoLoad
  2. Open for edit the following config file: {NeoLoad install dir}\conf\controller.properties.
  3. Go to the [Runtime] section, and add the following key:

    disable.cache.for.methods=PUT

    NOTE: comma separated list of HTTP methods where NeoLoad will not handle cache headers, such s POST,PUT,GET...

  4. Save the config file and restart NeoLoad.
  5. Test replaying the script to see if the If-None-Match header is not used by NeoLoad anymore.

Be carefull it will disable the cache for all your scripts within that controller.