Unanswered question

Unable to record through Neoload

All of sudden neoload stopped recording on both IE and Chrome . I have tried manually setting browser proxy as well. Looking for solution.

Vijayashree V.
Vijayashree V.

Vijayashree V.

Level
1
104 / 750
points

Answers

What is the behavior? Are you still able to reach your application while recording with NeoLoad? Chrome and IE share the same proxy settings. Have you tried with Firefox to check if you have the same behavior?

Do you have that issue whatever the URL you are trying to record?

Vijayashree V.
Vijayashree V.

Vijayashree V.

Level
1
104 / 750
points

Yes, irrespective of URLs, browsers I am facing this problem. yes tried even with Firefox. But same problem. Corporate is using proxy to connect to internet, I have configured this under 'application proxy'

Ok but you did not say if while recording you are still able to reach your URL's?

I'm trying to understand if the issue is going through your proxy. Also you confirmed that while recording the NeoLoad proxy "localhost:8090" is set in your browser and in NeoLoad application proxy is your corporate proxy right?

Since it worked before could you check if port 8090 is still available for NeoLoad?

Vijayashree V.
Vijayashree V.

Vijayashree V.

Level
1
104 / 750
points

Yes, i am able to reach URLs during recording is ON. Another observation, i am getting a below message in browser when i click 'start recording ' .
msg is : Proxy Configuration Failed

Further i have configured proxy as localhost:8090.

My theory would be for some reason Neoload is no longer able to set the proxy, this is likely to be permissions related, when you start Neoload, try running it as admin to see if it makes a difference. If Neoload isn't setting the proxy, then your application connects as normal and Noload isn't intercepting the traffic. Another solution is that you said you tried setting the proxy manually but when you initiated recording, did you still have the start browser checkbox checked. Try unchecking the box and open the browser yourself and see if anything is captured. Check in Neoload preferences that Neoload has your proxy defined and is using it (the 2 dropdowns in the proxy screen). We need to be able to forward traffic on to teh target host. Browser > Neoload > Website

Vijayashree V.
Vijayashree V.

Vijayashree V.

Level
1
104 / 750
points

1)Already tried running as admin, but same problem exist
2)Tried un-checking the box and open the browser myself, but same problem exist
3)Proxy drop downs are using my corporate proxy

Vijayashree V.
Vijayashree V.

Vijayashree V.

Level
1
104 / 750
points

This issue is resolved , Zscaler security was blocking the application from capturing