Answered question

How to avoid java timeout error?

After running my tests, I have a few errors like this:

Error detected by NeoLoad
Error Code: NL-NETWORK-01 Message: Network error: An IO error occurred sending the request. Details: java.util.concurrent.TimeoutException: Idle timeout 300000ms
Please refer to the documentation for further details and advice

How can I avoid that? (Further to my previous q http://answers.neotys.com/questions/1874290-want-change-default-timeout-setting-5mins-can#answer_4286333 I have added the two .timeout-settings=0 to the .nlp-file)

Michael B.
Michael B.

Michael B.

Level
0
63 / 100
points
Neil W.
Neil W.

Neil W.

Level
3
4738 / 5000
points
Team

I've not heard of editing the project file before (.nlp). The help link in your other post refers to the controller.properties file which is part of you Neoload install.

In Terms of this question, it looks like you have reached the upper limit of your server, you would need to work with your development team to understand this limit

Did you find this useful ?

No (0)

Yes (0)

0% of users found this answer useful

Other answers

Neil W.
Neil W.

Neil W.

Level
3
4738 / 5000
points
Team

nlp file? I assume you mean the controller.properties. The error indicates that the your application failed to respond to a request within the timeout, it could be caused by a number of things. Does it happen every time? is it specific to a particular load generator? etc

Michael B.
Michael B.

Michael B.

Level
0
63 / 100
points

@Neil W. (This "answer" relates to yours. I did not see another way to reply)
.NLP-file, indeed. This file is created in the project-folder and contains a few settings, so I added to it the two lines

runtime.connection.timeout=0
runtime.so.timeout=0

This happens on a very basic test - I'm just attempting to open a page (want to test the server itself) - and it works fine as long as I have 22 sessions, but I start getting these errors as soon as the 23d user is created.