Answered question

Result Data are not getting filled when Neoload Scripts are ran by Jenkins?

Jenkins is configured to take Neoload scripts from git and run it with Neoloadcmd.exe. Neoload plugin is configured with jenkins.
Now Jenkins successfully runs the script, but I couldn't see the neoload graph tends working, neither results generated by jenkins run on neoloads provides basic data result about the Run.

Kindly provide a solution.

RUDRA GANESH S.
RUDRA GANESH S.

RUDRA GANESH S.

Level
1
124 / 750
points

I can see in the first screenshot about the global summary, that an automatic filter has been applied to keep only the first two seconds of the test (note that the filter interval is the period to keep, not to exclude)

You should check your automatic filter settings in the 'Automatic filter' tab of 'scenario1' settings.

Did you find this useful ?

No (0)

Yes (1)

100%

100% of users found this answer useful

Other answers

From the output i do not see a line mentioning "Archiving artifacts". That would explain why you can't see any Trends statistics.

You have to add a post-build action to archive your artefacts like described in the documentation and run multiple successful build.

The second issue is that you did not get any statistics in NeoLoad report. In you check the Values tab do you see any count for any of the requests/transactions?

It seems that you put most of your transactions (maybe all) inside the Init container. That container is only executed once by all the virtual users. You should instead put your transactions under Actions container and eventually leave your login/logout transactions inside Init/End containers.

 

RUDRA GANESH S.
RUDRA GANESH S.

RUDRA GANESH S.

Level
1
124 / 750
points

Thanks Nouredine A,
Resolved with Refresh NeoLoad trends.

Yet issue with Neoload Reports
I have already placed the transactions in init-action-end respectively. the result page screenshot displays init-action.
still I couldn't get the values of iterations and transactions.

Where as when I run the same script in Neoload standalone it provides proper result.

Kindly suggest a solution.

What are the other statistics from the jenkins test? Especially the errors? It looks like the test entirely failed to run in the Jenkins environment.

Can the tested application be reached from the Jenkin's NeoLoad?

RUDRA GANESH S.
RUDRA GANESH S.

RUDRA GANESH S.

Level
1
124 / 750
points

Thanks for responding christophe M,

1.Yes, the application is reachable from Jenkins
2.The same script when ran from Neoload works perfectly.
3. But doesn't produce results when run in jenkins.
Kindly find the screenshot of other statistics and provide solution

RUDRA GANESH S.
RUDRA GANESH S.

RUDRA GANESH S.

Level
1
124 / 750
points

Wow! Christophe M Now it works. Thanks a lot