Unanswered question

Neoload GET action URL has port number

Howdy!
I'm new to Neoload and am working to learn it so that I can recreate a lot of Postman microservice API tests into it for CI/CD and overnight batch testing.
.
.
The requests I'm beginning with are pretty simple, they have a hostname, directory path, service name, and endpoint.
Such as:
https://servername.com/api/folder/scheduler/whoami
.
However, when I build a Server definition and refer to it within a UserPath-Action, the request always ends up looking like this: https://servername.com:NNNN/api/folder/scheduler/whoami
.
where :NNNN is the port number as defined in the Server definition.
(The Server definition screen will not allow me to remove the port number.)
.
Testing in Postman shows that any port number in the request URL breaks the request..(It's possible this is because of vTM device networking rules which handle load balancing between multiple instances of the microservice.)
.
.
How can I remove that port number from my User Path Action URL?
.
.
Thanks in advance!
.
B.

Brian B.
Brian B.

Brian B.

Level
0
1 / 100
point

Answers

Neil W.
Neil W.

Neil W.

Level
3
3258 / 5000
points
Team

This can't be done, port number is a required parameter, as this is https, you should use 443, the default port used for https. If your server doesn't accept a port, I'm not sure what to suggest as this is unusual and not the standard behaviour I would expect from your server