Answered question

Oracle forms recording, request content appears encrypted and the 1:initial_version page does not load?

I have been trying to record an oracle forms application using neoload. The recording downloads a large number of jars as expected, and then the application hangs. Refreshing the browser allows me to get to the login page and log in. Once I have clicked on one of the application icons that triggers the oracle forms request I get a large number of requests containing a small amount of what looks like encrypted/binary data.

I believe it should be trying to download some configuration, I have seen mention of a page titled "1:initial_version" that does not load.

Is there any configuration within Neoload that I have missed when trying to configure the oracle forms?
I have placed the frmall.jar in the ext directory, and I have deleted the Recorder patterns from the Oracle Forms -> General Settings (and have added a blank entry as I have read in another thread)

Any help will be greatly appreciated.
Chris

chris W.
chris W.

chris W.

Level
0
53 / 100
points

Have you loaded the NeoLoad Root certificate in your browser? You have the procedure available in the NeoLoad documentation here

I can't reproduce your issue on my side. I tried to record your application until the login page and it worked fine with the settings i provided.

Make sure that you do not have any specific security settings in your browser when you are reaching an application through a proxy since it's the case when you are recording with NeoLoad.

 

Did you find this useful ?

No (0)

Yes (1)

100%

100% of users found this answer useful

Other answers

All your requests have the "normal" HTTP icon but instead we should see for some of them the Oracle forms icon. That means that NeoLoad did not identify them as Oracle Forms requests.

Your preferences may not be correct. If you look at the NeoLoad preferences-->General settings under Oracle Forms item. Do you have "application/octet-stream" as Content-Type value?

Also in the header column instead of a blank line i would suggest you to only have a line with "Apache" instead.

In the "User Agent" column you should have the default settings which is:

(.*)java([0-9]*|\.)*-internal(.*)

(.+)Java/([0-9|.|_]+)

And of course the frmall.jar file should be copied inside <install_dir>\lib\plugins\ext and a restart of NeoLoad is needed.

 

 

chris W.
chris W.

chris W.

Level
0
53 / 100
points

Hi,

I have attempted the steps that you have suggested below.
I have added

(.*)java([0-9]*|\.)*-internal(.*)
(.+)Java/([0-9|.|_]+)

into the User Agent column in the Oracle Forms settings.

Neoload is now identifying the queries as oracle forms requests.
However these requests are now coming through as "empty_request".

When recording, neoload is showing lots of "empty_request".
I dont think this is recording correctly. Is there any further adivce you can give?

Thanks very much

Did you add the "Apache" line like suggested in my comment?

"Also in the header column instead of a blank line i would suggest you to only have a line with "Apache" instead."

chris W.
chris W.

chris W.

Level
0
53 / 100
points

Hi,

I did try with Apache in the header column.
The recording appeared to freeze after downloading some of the required jars into the browser cache. No oracle form requests were recorded.

I am retrying the recording with Apache in the header column now.

chris W.
chris W.

chris W.

Level
0
53 / 100
points

I have retried with Apache set in the headers setting.
The recording seems to freeze during the jar download. <recording_6>

When I remove Apache from the headers setting, the recording gets further and I get the following warnings when loading the application <recording_7> and <recording_8>

Even if I tick "Always trust content from this publisher" I get the warning when I restart the recording.

These popup windows do not appear to trigger if I have "Apache" set in the headers settings.

Is there something I need to do with the self signed certificate to bypass these settings?