Unanswered question

How to resolve 'NeoLoad certificate installation alert' in Google Chrome browser?

On Start of recording by choosing Chrome browser, 'NeoLoad certificate installation for HTTPs recordings' alert message is being displayed. I tried with both options 1.Start automatic installation and 2.Download the certificate and installed root certificate, added to Trusted Root Cert. Auth. as mentioned in Document. And re-started NeoLoad. Cleared browser cache and Tried. Not able to record any URL even http either.
I am using NeoLoad 5.4.0.(64-bit) and Google Chrome 58.0.3029.110 (64-bit) on Wiindows 7 Pro(64-bit) with 8GB RAM i3 2.6GHz machine. Please help me out to resolve.

Sumith H.
Sumith H.

Sumith H.

Level
0
1 / 100
point

Answers

Nouredine A.
Nouredine A.

Nouredine A.

Level
4
5000 / 5000
points
Team

Since Chrome 58, the NeoLoad ROOT certificate is not accepted anymore. Chrome expects a "subjectAlternativeName" in the ROOT certificate that is not present.

An updated version of that ROOT certificate is going to be available next week with a NeoLoad 5.5.2 patch.

Meanwhile you can add an entry in the Windows registry to avoid that issue.

First ensure Chrome is not running in Task Manager and run the following command in a DOS window with administrative privileges:

reg add \\{hostname}\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome /v EnableCommonNameFallbackForLocalAnchors /t REG_DWORD /d 1 /f

Replace {hostname} by the hostname of your machine. You can get it from the "hostname" command executed in the DOS window.