Unanswered question

Setting SSL pfx Certificate for custom JSON Request at Runtime

Neoload is not including the pfx certificate I've added to the certificate manager during playback of the user paths. This is causing "forbidden resource" errors.

Server side logs suggest that neoload is not including these certs as part of the transaction. How do I explicitly include the certificate during playback?

Ferdinand N.
Ferdinand N.

Ferdinand N.

Level
0
14 / 100
points

Answers

Could you confirm that in the NeoLoad preferences under Project settings tab-->Security manager and Runtime section you selected to use the same as recording or even one per virtual user?

Ferdinand N.
Ferdinand N.

Ferdinand N.

Level
0
14 / 100
points

Not sure how to respond to you directly, but yes.

I have configured a working pfx (I have a client sourced C# application to verify this) as part of the Certificate Manager preferences. Nothing is being sent to the client server. I'm a Neotys partner, perhaps contact me directly and let set up a remote session to discuss.