Unanswered question

Replay use HTTP2 protocal instead of HTTP1.1

Here is the HTTP request in the design HTTP/1.1

GET https://connect.facebook.net/en_US/fbevents.js HTTP/1.1
Accept: application/javascript, */*;q=0.8
Referer: https://stag2.readyrefresh.com/index.cfm?badzip=1800
Accept-Language: fr-CH
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko
Accept-Encoding: gzip, deflate
Host: connect.facebook.net
DNT: 1
Connection: Keep-Alive

Here is the HTTP request in the replay HTTP/2.0

GET https://connect.facebook.net/en_US/fbevents.js HTTP/2.0
Accept-Encoding: gzip
Accept: application/javascript, */*;q=0.8
Accept-Language: fr-CH
DNT: 1
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko
Referer: https://stag2.readyrefresh.com/index.cfm?badzip=1800

Why it's not using the same one ?
How can I change it ?

I am getting HTTP400 and I think it's due to this pb (with IE and fiddler I am able to pen this file - http code 400)

Thanks and regards,
Laurent

Laurent G.
Laurent G.

Laurent G.

Level
1
185 / 750
points

Answers

Nouredine A.
Nouredine A.

Nouredine A.

Level
4
5000 / 5000
points
Team

Normally if NeoLoad records in HTTP1 it should also replay with HTTP1. Maybe your browser did not support HTTP2 or it has been deactivated and so NeoLoad uses HTTP1 to record but HTTP2 to replay.

Regarding the HTTP 400 error it migth be an issue with the request header that NeoLoad does not send in the same way.

Same issue is being investigated by NeoLoad developers.