Unanswered question

websocket error in 5.2 Beta

I've installed the Beta 5.2 of NeoLoad and migrated a project created with NeoLoad 5.1.4. The migration process succeeded but if I try to validate the recording, I'm always getting the following error:

Error Code: NL-WEBSOCKET-CHANNEL-ENGINE Message: Error occurred while executing WebSocket channel. Details: org.eclipse.jetty.websocket.api.UpgradeException: Didn't switch protocols, expected status <101>, but got <302> at org.eclipse.jetty.websocket.client.io.UpgradeConnection.validateResponse(UpgradeConnection.java:352) at org.eclipse.jetty.websocket.client.io.UpgradeConnection.read(UpgradeConnection.java:280) at org.eclipse.jetty.websocket.client.io.UpgradeConnection.onFillable(UpgradeConnection.java:196) at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:264) at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:95) at org.eclipse.jetty.io.ssl.SslConnection.onFillable(SslConnection.java:197) at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:264) at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:95) at org.eclipse.jetty.io.SelectChannelEndPoint$2.run(SelectChannelEndPoint.java:75) at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.produceAndRun(ExecuteProduceConsume.java:213) at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.run(ExecuteProduceConsume.java:147) at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:654) at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:572) at java.lang.Thread.run(Thread.java:745)

I've recorded the same scenario with 5.2 Beta but the validation of the recording causes the error described above.

Running the validation in NeoLoad 5.1.4 works as expected. Any suggestions?

Best regards

Sebastian P.
Sebastian P.

Sebastian P.

Level
0
13 / 100
points

Answers

The HTTP client is completely different between 5.1.xx and 5.2.0 so it might be a regression that has not been identified yet.

I think you should open a ticket to the Neotys support including an export of your 5.1.xx project and the log files from your 5.2 version.

You can get them from the menu "Help-->Open logs folder....". Ideally if you could get those logs right after reproducing the replaying issue it would be great.

Sebastian P.
Sebastian P.

Sebastian P.

Level
0
13 / 100
points

Thanks for your suggestion. While analyzing the sent request in NeoLoad 5.2 I've noticed that it doesn't add a COOKIE to the request header while NeoLoad 5.1.4 does.
There are no errors in the load generator-checkvu.log file except the one I've posted above. The neoload.log doesn't contain any errors when executing the validation.
I'll open a new ticket as soon as possible but I won't be able to add an export of the project because it contains some of our closed source libs.

If you can't send the project then maybe a screen shot of the request sent by NeoLoad 5.1xx and 5.2.xx showing us the cookie differences and/or any other differences.

Thanks